ABS, Brake,Tire Pressure light & now CEL

Discussion in 'Stock Performance/Mechanical' started by x-driver21, Mar 14, 2019.

  1. x-driver21

    x-driver21 Member

    Joined:
    Nov 14, 2010
    Messages:
    310
    Likes Received:
    0
    It has been a fun night and i cant seem to catch a break.

    I had some gauges installed a couple weeks ago in the pillar and connected to the fuse box via double piggy back style fuse in the ignition fuse location. The abs, brake light, and tire pressure light have came on a couple times. I initially thought the piggy back was to blame. I could turn off the truck, unplug the fuse and turn back on the truck, turn off the truck and plug the fuse back in and they would be gone.
    *note: the first time this happened my a/c just blinked

    WELP
    NOT TONIGHT

    When these lights come on the ac has no power, no lights, no function.

    My Windows loose all power.

    Ive tried leaving the piggy back unplugged and just doing a normal single fuse and no luck.

    THEN my CHECK ENGINE LIGHT CAME ON! What is this MADNESS! It’s 11pm at night!!
    -and the real kicker is my window in rolled down when the lights came on. So yea, I’m frustrated

    Ive tried disconnecting the battery and Ive checked the fuses

    Anyone know what’s going on!?!?!?!?!?
     
  2. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,819
    Likes Received:
    235
    Knowing the CEL code would be helpful. As for the other issues it initially sounded like your gauges are drawing too much but the fact that it's not blowing the fuse is throwing me for a loop. And going back to "stock" without the gauges doesn't solve the problem? I have 4 gauges, and I'm pulling from two separate locations with "add-a-fuse" circuits.
     
  3. autobodyX

    autobodyX Active Member

    Joined:
    Aug 8, 2010
    Messages:
    855
    Likes Received:
    29
    Seams your illumination leg of the gauges is back feeeing to the Body control module. How and what have you hooked the gauge inputs to?
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.