huge failure

Discussion in 'Stock Performance/Mechanical' started by Toyotaguy_7, Dec 14, 2009.

Tags:
  1. Toyotaguy_7

    Toyotaguy_7 New Member

    Joined:
    Aug 22, 2007
    Messages:
    951
    Likes Received:
    0
    help in Iraq my truck at home alone in the cold with dash lights on low tire pressure light, cel, brake, abs plus the a/c light flashes what the H is going on here need input please.
     
  2. KETCHUP

    KETCHUP Active Member

    Joined:
    Nov 1, 2007
    Messages:
    11,665
    Likes Received:
    3
    wow, that doesn't sound good. do you have a scan guage II? If not, auto zone can do a scan on the code. I would have someone disconnect the battery. Leave it for a few and then reconnect. That will re-set the computer. Has it been sittin for a while, or has someone been driving it?
     
    hypertaco likes this.
  3. SX TOY

    SX TOY Active Member

    Joined:
    May 23, 2009
    Messages:
    1,965
    Likes Received:
    0
    is there a local e mail or phone # of someone that can walk through the problem.
    there are a few questions to ask.
    it is cold so it could be as simple as cleaning the battery posts and charging it.
    did it stall/die and not start back up or will it just not start?
    ac flashing could be a secondary prob
     
  4. ntinhri

    ntinhri Active Member

    Joined:
    Feb 1, 2007
    Messages:
    8,104
    Likes Received:
    2
    How olds the battery? How cold has it been, low battery will cause nasty things to happen. I'd check the battery with volt meter. Also unhook the battery for 30 - 60 seconds and try to honk the horn while its unpluged. Hook it back up and see what happends. I assume some one elses is driven ur truck while ur away, I'd ask them if they ran over any thing that they know of. Maybe the ac power wire has come loose and flying around causen it to flash as it makes contact. Also check the codes. If there is a code, we can help much more!!
     
  5. lamecargo

    lamecargo Active Member

    Joined:
    Sep 15, 2007
    Messages:
    1,306
    Likes Received:
    1
    Now turn the key a little more.........:dontknow:.......JK but that does sound nasty
     
  6. Toyotaguy_7

    Toyotaguy_7 New Member

    Joined:
    Aug 22, 2007
    Messages:
    951
    Likes Received:
    0
    thank you much i'll get to them the battery 2 plus yrs with sub running off it for the whole time. been cold enough for ice. when you hit the a/c button it quits flashing for a little. it's throwing o2 code might because of the simulator? it has stalled out
     
  7. Toyotaguy_7

    Toyotaguy_7 New Member

    Joined:
    Aug 22, 2007
    Messages:
    951
    Likes Received:
    0
    bump.... bump
     
  8. dailycruzr

    dailycruzr New Member

    Joined:
    May 14, 2008
    Messages:
    333
    Likes Received:
    0
    lol i get it!!!!:biggrin: nice one!
     
  9. ntinhri

    ntinhri Active Member

    Joined:
    Feb 1, 2007
    Messages:
    8,104
    Likes Received:
    2
    whats the code?

    what happend after you unplugged the battery?

    have them have the battery checked..
     
  10. blastap

    blastap New Member

    Joined:
    May 20, 2007
    Messages:
    4,247
    Likes Received:
    1
    the x1 needs to be fully seated into the harness. if its a o2 code then the x1 is not working or not seated
     
  11. ntinhri

    ntinhri Active Member

    Joined:
    Feb 1, 2007
    Messages:
    8,104
    Likes Received:
    2
    he has x-1? yup its the x-1!
     
    thewarriordinghy likes this.
  12. Toyotaguy_7

    Toyotaguy_7 New Member

    Joined:
    Aug 22, 2007
    Messages:
    951
    Likes Received:
    0
    well if the battery don't work then i''ll push on it when i get home for leave
     
  13. 5000XD

    5000XD New Member

    Joined:
    Jan 15, 2007
    Messages:
    3,774
    Likes Received:
    0
    I say it's the battery!
     
  14. x-driver21

    x-driver21 Member

    Joined:
    Nov 14, 2010
    Messages:
    310
    Likes Received:
    0
    Was there a verdict on this? Just happened to me tonight!
     
  15. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,799
    Likes Received:
    230
    Ten year old thread bud......but if you have an X-1 make sure the ECU harness plugs are pushed all the way in, they were known rattling loose.
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.