Re-Installing My Supercharger

Discussion in 'F/I Mods & Tuning' started by iniazy, Aug 18, 2014.

  1. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Yup. I am with Gadget. When is the last time you checked, or cleaned your air filter?

    I had a really clogged one once, when mine was rear mounted. Was a pig off of the line and through acceleration. Wouldn't even hit boost, and I had a 8 psi spring in there. Pulled the air filter snorkel off of the turbo and bam! Truck ran like a champ!

    The filter was horribly clogged.
     
  2. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I guess I need to check my air filter, it's been a while since I last cleaned it.

    There's bad news. I cracked a piston finally. Last night when I took the car for a wot run it knocked bad because the low boost took the fuel map to places not previously tuned properly making it a little lean, and since I drove back the engine never came back to normal. It's blowing out oil vapor like crazy, and lost lots of power. A round trip to work blew out almost a half a quart. I work 60 miles away.

    Time to rebuild my old engine.
     
  3. Gadget

    Gadget Well-Known Member

    Joined:
    Jan 13, 2007
    Messages:
    10,720
    Likes Received:
    52
    Maybe your problem was with your MAP sensor.
     
  4. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I have a boost gauge along with the map sensor, and the two are consistent in their reading, and my but dyno concurs. So I think map sensor is fine.
     
  5. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Have you checked the air filter yet?
     
  6. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    Not yet. Filter needs a few hours to clean up so I'm waiting for my Miata to come out of service so I can have another car.
     
  7. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I checked the air filter, it was dirty. Really dirty. I cleaned it up properly and oiled it, and checked with my mouth to see the difference in flow, and it made a big difference.

    After cleaning it I also removed that ugly 3" joint box that came from Alpine, which was probably adding a lot of air flow restriction, and just connected everything through normal 3" silicone couplers, and now I feel the engine really powerful, even while running with only five good pistons! I wish I did that before I cracked the piston. The car feels so strong I can hardly believe there's a cracked piston, if it weren't for the jerkiness when I stop while on Drive in a traffic light, or if it weren't for all the oil that's being consumed/blown out of the crank case breather.
     
  8. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Crazy what a little "restriction" will do huh? ;)
     
  9. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    @iniazy , which 1GR vehicles over there have the 5 speed transmission?
     
  10. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    1. Fortuner 2006-2015 Single VVT
    2. Land cruiser LC200 2008-2011 single VVT and 2012-present dual VVT
    3. Land cruiser 70 series 2010-present single VVT
     
    Torspd likes this.
  11. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Awesome! Thanks!
     
  12. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,179
    Likes Received:
    55
    a
    Are you thinking what I'm thinking? 5spd swap from overseas?
     
  13. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Not for me, but thought about it for years. Brought it up many a time. Got another thread going where the topic is being discussed.

    Subsequently though, yes. The R154 is a beast of a trans. The R155, I am not so sure of. I am curious what the bolt patter of each of those transmissions looks like sided by side. Without the bellhousings attached.
     
  14. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
  15. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I think they should have identical bolt patterns. I think the differences are in gear ratios only.
     
  16. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    You wouldn't happen to have any pictures of the 5 speed transmission without the bellhousing attached, would you?
     
  17. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I'll try to find something.

    One thing I know, the 70 series Land cruiser five speed is probably very different than the one in a fortuner and LC200. The 70 series have completely different ratio gears, geared for heavy towing rather than smooth driving. Also, I saw the bell housing and it seems very long, seems much longer than the one in the fortuner. The transfer case also is different, it is old school gear driven, rather than chain driven as in the fortuner and LC200, with a different shifting pattern and really hard to engage compared to the chain driven one.
     
  18. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,757
    Likes Received:
    33
    Hmm. Let's stick the the Fortruner one then. Seems closest.
     
  19. iniazy

    iniazy Active Member

    Joined:
    Jan 29, 2014
    Messages:
    490
    Likes Received:
    29
    I'm so frustrated with my supercharger. I'm continuing to lose boost by the day, now I'm NA-close 3 PSI only! I thought it was the belt, so I just replaced that with a one that fits very tight, but it's still really down in boost. What's going on?

    Only possible thing is my rotrex supercharger is losing efficiency. But no one ever had that happen to them, according to my research. The rotrex always just breaks, never seen any one reporting loss of efficiency.

    I want to buy a replacement, but I'm worried it would turn out from something else, and $2500 is not pocket change.

    Any suggestions?
     
  20. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,179
    Likes Received:
    55
    Send it to Stiegemeier for a rebuild. Should be way cheaper than an entirely new unit.
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.