stoner-x turbo build

Discussion in 'Member Builds' started by STONER-X, Aug 15, 2012.

  1. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    With the top mount it is near the rear passenger side of the motor...
     
  2. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    I had a feeling. The wires just aren't that long, compared to say the AEM UEGO. Which are extremely long. There is a grommet on the passenger firewall, as well as the well known driver side grommet. You might have to get an extension or splice the wires.
     
  3. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    I'm not scared to splice.. i just don't want to if not needed... I saw the passenger side grommet.. I'll have to take a peek and see if it can reach with out extending...

    If those two holes are my only option I'll pick one.. (haha no pun) I just didn't know if there was a "secret spot"

    .



    Btw ..... is Alex still at power fab? I have not seen him on here in a long while that I can remember. ..

    I need to find a "speed shop" to fix my pipes I had to make fix around the oil pan
     
    #203 STONER-X, Jun 26, 2014
    Last edited: Jun 26, 2014
  4. rennurx

    rennurx New Member

    Joined:
    Sep 22, 2011
    Messages:
    1,736
    Likes Received:
    0
    Poked a hole in the rubber boot at the steering shaft for my wires.. and the maf was rotated s the wires were almost strait up..

    Might be a pic on my build thread.

    I have my oil pan just sitting here i could of gave you lol
     
    #204 rennurx, Jun 26, 2014
    Last edited: Jun 26, 2014
  5. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Alex is not a PowerFab any more. They could do it, but I trust Kozmic Motorsports much more.
     
  6. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    Thanks.. my gut feeling told me they should be up like factory position...

    I'll pass on the oil pan haha with as much of a pita it was to change that thing is not coming off lol..



    Mark where abouts is this shop you speak of?

    Just googled it... is it near 1960 and mills?
     
    #206 STONER-X, Jun 27, 2014
    Last edited: Jun 27, 2014
  7. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Correct. They know me there. Good people. :top:
     
  8. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    Thanks Mark


    Yall think extending the sensor cable about 4 foot would cause a problem?
     
  9. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Shouldn't. You'll know woo enough if something isn't working right.
     
  10. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    Cool... I'm at work so I'll extend the wires before I leave..

    I got the maf adjusted and WOW did it make a huge difference in the trims... they are close to zero now

    Yesterday I got my 10an oil drain kit in the mail so I will Install that today.. i have been scavenging through 8an lines like before durrung the disassembly I managed to strip the threads where my old oil drain is and that thing is leaking oil pretty bad... oil leak should be gone today..
     
  11. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Good deal.

    You'll have to come by soon and let me check it out!
     
  12. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    How sensitive is the MAF sensor? I accidentally dropped mine while doing the install and now I have that same weird super rich condition randomly when I go to boost.... Some times it will run up to red line other times it will start to pull the lose power and go rich.. ?


    Even worse when I got everything running I broke my boost line to my gauge so I had been watching my afr and I did a test boost run...

    Punched it and the truck TOOK OFF fast... looked at my afr and it was constantly climbing probably got to 15 before I realized what was happening.... got to a stop light and my truck blew off a vacuum line. Drove it easy no boosting... This weekend I fixed my boost gauge. .. took it for a spin did a quick pull an WTF my gauge went to 15PSI! !!!!!! Shut it down real quick less than a second... truck still running fine

    Got home took the waste gate off and my dumbass for got to put a plug in one of three air ports wow... got it hooked up right and now the truck is seeing 5 psi on a 7psi spring after the intercooler... now that is running right.....


    Let's just hope I didn't break nothing...

    I'm hoping that the problem I am having is due to a messed up maf... everything sounds good numbers look good... time will tell....
     
  13. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Probably damaged the MAF.

    Tiny little sensors in there.
     
  14. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    I sure hope so...

    found a maf on rockauto for $70 shipped... New not remanded.
     
  15. rennurx

    rennurx New Member

    Joined:
    Sep 22, 2011
    Messages:
    1,736
    Likes Received:
    0
    I have my maf message me.. lol just text me 4843666965 I have all the stuff u need.. probably.. lol
     
  16. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    Will hit you up sometime tomorrow
     
  17. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    I am on. The right tracking to my issues....

    I removed the airflow straightner and that seemed to cure the problem with it losing power in the high rpms....it has a few spots that looked like it was bumped while being shipped.. didn't think much of it and straightened them out guess that was not good enough.... but now of course I picked up an unstable idle at times...

    Next on the list is get the exhaust redone to fit arount the oil pan.. I think I'm getting a ton of pack pressure on that side of the motor...

    Once I get all of this squared away I'll put in the larger injectors (rc 550) and see what happens..
     
  18. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Slowly but surely. :top:

    Remember, you have my number as well and are more than welcome to call me if you need help.
     
  19. STONER-X

    STONER-X Active Member

    Joined:
    May 15, 2008
    Messages:
    3,367
    Likes Received:
    1
    Pretty excited... think I got the last of my tuning issues figured out. ... just a recap..

    In a 2nd or 3rd gear pull the truck would get into the 4000 rpm range and fall on its face with huge power loss... scanner showed it was pulling timing....

    Problem airflow straightener material was damaged durring shipping no one's fault.. I saw it tried to straighten it out and it didn't work..

    Took it out and had an erratic idle at times... but timing issue was a ton better... but now truck seemed to stumble between shifts. ..

    After a week and a half of scanner reading and studing ... I concluded I still had a TON of air turbulence. ... maf readings were unstable at idle and at stable speeds... afr was constantly changing at idle and at stable speeds..

    Before I went out and spent money on an airflow straightener I wanted to make sure I was right....

    What did I do? Lol here I go.... just remember it worked

    Window screen.....

    Back of a box fan.. it is grated and finned..

    Took screen and put it over the tube and took the box fan part then put some more screen on the other 8sde to make sure it stays straight and don't move or fall...

    Went a drove around the afr's were solid and maf reading was stable and the pull was smooth and repeatable plus the stumbling between shifts are gone...

    I had a few people telling me. To get it tuned but I knew it was not the tune. . I had a stable tune... I'm still on the TRD reflash and running great. .

    I'll try to post pics but I have been having problems lately posting from my phone....
     
  20. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    39
    Basically the same thing that is on GM vehicles. Theirs is just a mesh screen too. Ever the innovator. Good job. :top:

    So when are you going to come by and give me a test drive????

    How's your GF liking it now?
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.