TRD S/C ECM Reflash with the normally aspirated set up!!

Discussion in 'F/I Mods & Tuning' started by hybrid2.0, Apr 8, 2012.

  1. hybrid2.0

    hybrid2.0 New Member

    Joined:
    Dec 30, 2008
    Messages:
    79
    Likes Received:
    0
    People,
    Need help urgently!!, what do you think??

    Recently I switch from the TRD s/c setup to the naturally aspirated setup again. The thing is that after finish the swap and do the first run, it shows a crazy fail!!, doesnt respose!! Runs like a shiet!!,
    After a couple of minutes it shows the following codes : P0171 and P0174.
    I started the troubleshooting cleaning the MAP sensor with alcohol (it was really dirt), then after that i ensure all vacuum lines are properly routed and fixed. Everything looks fine!!.
    I had no choice then and I took the truck to a near toyota dealership. After 5 or 6 hours of troubleshootin of the technicians, they can't figure out which was the problem and finally deduced that the most probable root cause of the problem is that the ECM still with the TRD programing reflash for the SC,

    They told me that there is no way to get the computer back to the factory settings and I would need to purchase a new one!!

    Any recommendations??

    Does any one have a stock ECM that can sell me or borrow me in order to confirm their theory?
     
  2. outlaw7

    outlaw7 New Member

    Joined:
    Apr 18, 2010
    Messages:
    633
    Likes Received:
    0
    Did you leave the yellow s/c injectors in? If not that's probably your issue.
     
  3. blackx-runner

    blackx-runner "White Flash"

    Joined:
    Jan 14, 2007
    Messages:
    7,565
    Likes Received:
    8
    Like posted in your other thread you can not just swap ECMs. It doesn't work like that anymore. You would have to buy a new unit and get it flashed for your truck.

    Your best option is going to be putting the TRD injectors back in the truck. Its mapped for larger injectors so of coarse its going to run like shit with different injectors in there. I know Ntinhri did this when he traded in his truck, says it ran fine with the TRD flash, TRD injectors and no blower.
    You should have come here and asked first so you didn't waste 5-6 hours at toyota having them trouble shoot the issue.
     
  4. hybrid2.0

    hybrid2.0 New Member

    Joined:
    Dec 30, 2008
    Messages:
    79
    Likes Received:
    0
    No, I took them off and put the factory ones.

    The thing is that I posted the entire SC setup for sale.

    Anyway , I' ll need to install them again to see if it fix the problem.

    Thanks very much guys!!

    Let you know later if it works.
     
  5. Murderface

    Murderface New Member

    Joined:
    Feb 27, 2008
    Messages:
    11,937
    Likes Received:
    0
    It should work, if ur not seeing boost then the ECM won't dump the extra fuel
     
  6. hottacoX

    hottacoX Moderator
    Staff Member

    Joined:
    Dec 21, 2009
    Messages:
    4,821
    Likes Received:
    2
    Outlaw called it! You need to leave the yellow sc injectors in the motor for it to work. Put them back in and you should be good to go. Most trucks won't take a used ECU you would have to buy a new one and flash that
     
  7. blackx-runner

    blackx-runner "White Flash"

    Joined:
    Jan 14, 2007
    Messages:
    7,565
    Likes Received:
    8
    The TRD injectors do come up for sale sometimes. Usually when someone upgrades to the larger 660 (E85) injectors. You may be able to get an extra set and still sell the kit complete.
     
  8. hybrid2.0

    hybrid2.0 New Member

    Joined:
    Dec 30, 2008
    Messages:
    79
    Likes Received:
    0
    Problem Solved Guys!!

    Run Nice and smooth with the TRD injectors.

    Thanks very much!!
     
  9. xrgilly

    xrgilly Active Member

    Joined:
    May 1, 2010
    Messages:
    2,315
    Likes Received:
    2
    thats the best thing about this forum ask and u get an answer and its often so simple
     
  10. Superloki24

    Superloki24 Member

    Joined:
    Oct 24, 2009
    Messages:
    181
    Likes Received:
    7
    I hate to revive an old thread, but I assume that if I was to install the TRD S/C injectors into my truck (stock flash on the ECU) and then drive it to the dealership to get re-flashed for the S/C it would run like crap right?
    Would it harm it at all or just make it run really rich?
    FYI I live about 60kms (35miles) from the dealership.
     
  11. Slywhitty

    Slywhitty "Midget Magnet"

    Joined:
    Jan 26, 2008
    Messages:
    3,362
    Likes Received:
    3
    Giving up on waiting for a ucon? Lol. I know lots have drove to the dealership after installing their blower for the flash. Just take it easy. Stay out of boost and you should be fine. I could be wrong though so we will wait for a concrete answer from someone who has done it
     
  12. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,237
    Likes Received:
    65
    I installed the TRD S/C in my garage. Keep it under 2K rpm and 50% throttle. You'll be fine. I drove 29 miles one way.
     
  13. o0opackersfano0o

    o0opackersfano0o Active Member

    Joined:
    Jun 23, 2016
    Messages:
    252
    Likes Received:
    42
    If you were in Maine I could do it for you and come to you lol. No ones in Maine tho.
     
  14. Superloki24

    Superloki24 Member

    Joined:
    Oct 24, 2009
    Messages:
    181
    Likes Received:
    7
    Lol, yeah I can't wait any longer. The 100,000km mark was passed a month ago, so the warranty issue is no longer an issue and the supercharger must go on. I might get a MAF cal to supplement the TRD reflash and call it good enough. Should get me over the 300hp mark.

    Sounds good. I'll do that then. I'm sure I won't be keeping it under 50% throttle on the way back from the dealer though....haha. Thanks.
     
  15. NHXRUNNER

    NHXRUNNER "New Hampster"
    Staff Member

    Joined:
    Jul 30, 2007
    Messages:
    7,237
    Likes Received:
    65
    I gave the ECU some time to re-learn idle and such.....so I didn't get on it until the last 28 miles home...:)
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.