Bodykit Help

BlackXrunner05

Active Member
Okay I just spent a lot of money to have my whole bodykit, flares and bumpers repainted. Unfortunately, one of my front spoilers has a broken clip mount and is missing one all together.... Is there a way to repair the broken mount and perhaps make a new mount? Plus how would I attach them?
 

autobodyX

Active Member
[ame="http://www.amazon.com/Startech-HC102-Adhesive-Cable-Mounts/dp/B00008VFBE/ref=sr_1_2?ie=UTF8&qid=1424743742&sr=8-2&keywords=cable+tie+mounts"]These work good. I found them at Lowes HP [/ame]
[ame]http://www.amazon.com/Startech-HC102-Adhesive-Cable-Mounts/dp/B00008VFBE/ref=sr_1_2?ie=UTF8&qid=1424743742&sr=8-2&keywords=cable+tie+mounts[/ame]
 

autobodyX

Active Member
You just need to put something over the hole to cinch the tie to. A piece of hose or a paperclip or pen just something to span across the slot in the bumper.
 

BlackXrunner05

Active Member
So I bought a plastic welder. My plan is to create plastic L brackets and weld them to the back of the front and rear spoiler. I'll then drill a hole through the tongue and use a zip tie to fasten it.... One question though? What kind of plastic are our bodykits made of? Polypropylene...ABS?
 

asianized

Member
I've been using those clips from lowes for over 2 years now & there still holding on strong!! I epoxied them on and let it sit for a day & a half
 

BlackXrunner05

Active Member
I made L brackets from my old side skirt and epoxied them to the back of my rear kit.. I used a torch once the bumper spoiler was in place and bent the bracket over again. It's not going anywhere now. I have to do my front bumper spoilers now.
 

BlackXrunner05

Active Member
13775485_10208210573095014_6161294320560613804_n.jpg


This is the progress thus far! I still need to pull my front spoilers and epoxy my brackets to them tomorrow
 
Top