Welcome!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Rubbing issues

JiNsEiGaNaI

Active Member
Joined
Feb 20, 2011
Messages
1,424
Reaction score
4
Anyone on here have rubbing issues due to bigger tires/wheels? What is some of the trimming did you do? If we were to rub, it would be by the body mount correct? Back of FRONT fender. It looks like when you turn lock to lock, the wheel/tire will rub the square part that sticks out (i believe it is covering body mount)

Thanks for advice/suggestions
 

NHXRUNNER

"New Hampster"
Staff member
Joined
Jul 30, 2007
Messages
7,995
Reaction score
303
I wish I could help you out brother but my wheels don't rub. A proper wheel fitment usually avoids this issue. What are your wheel specs? What drop are you running?
 

JiNsEiGaNaI

Active Member
Joined
Feb 20, 2011
Messages
1,424
Reaction score
4
Thanks Steve, u always find the post. I searched but never can find it. But ill post pics of the part that rubs. I have the sitting sic drop. So I know there is the body bracket there. But i was wondering the options beside cut n weld the bracket. I was hoping I can melt or trim the plastic liner but idk what behind there.
 

Attachments

  • 20171217_201035.jpg
    20171217_201035.jpg
    170.8 KB · Views: 199
  • 20171217_201045.jpg
    20171217_201045.jpg
    140.6 KB · Views: 201

NHXRUNNER

"New Hampster"
Staff member
Joined
Jul 30, 2007
Messages
7,995
Reaction score
303
David's pics are being held hostage on Photobucket
We're working on that......Photobucket sucks but some other forums have found ways to download the files back to their own database....we're in the process of trying to do exactly that.
 
Top Bottom