TSB: 4.0 Engine Tick '05-'06

BLUE X

New Member
how about the 07 i have a very annoying ticking noise, and also when the truck in in idle u can hear like a little wining sound.
 

kfxpro32

New Member
yea i think the tick is normal mine does it too... can't find a exhaust leak or nothin my buddy has a DC tacoma and his does it...
 

HolyCow

New Member
Toyota engines usually all tick, I've had 4, 6, and 8s, and they all ticked. If you are running low octane fuel (the cheap stuff) if will cause some ticking. You can try running your tank down to almost empty, and then getting bout 5 gal of premium to test it. We had the same tick in our 4-runner, but I could never save up enough dough to put premuim in it. If you dont use the toyota oil filter, you may get a tick for about 30 seconds during a cold start, toyota filters have a valve in it to prevent oil from draining all the way out of the top end. Ive had ticking in the stock CAT converter before too.
 

Troskey

New Member
the tick i'm having is during acceleration like the tsb says...it's nothing like the tick i get while idle...i know that noise is normal...the stealership up by my parents' house was gonna replace the exhause manifolds...but they wouldnt have been able to do it until monday...and i gotta leave sunday...
 

jandino63

New Member
I have an 07 and I as well have this annoying tick whenever I accelerate. Has anyone had any success in getting this issue resolved? Has anyone tried going from regular gas to mid grade or premium? Also is it bad for the truck to go from 87 to midgrade? Thanks
 
Last edited:

Stevenredx

New Member
I have an 07 and I as well have this annoying tick whenever I accelerate. Has anyone had any success in getting this issue resolved? Has anyone tried going from regular gas to mid grade or premium? Also is it bad for the truck to go from 87 to midgrade? Thanks

No real fix, it's just the nature of the 1gr engine.
 

rich017

Active Member
I have an 07 and I as well have this annoying tick whenever I accelerate. Has anyone had any success in getting this issue resolved? Has anyone tried going from regular gas to mid grade or premium? Also is it bad for the truck to go from 87 to midgrade? Thanks

It's normal. I can hear mine tick also while cruising or accelerating.
 

DC29

New Member
if you dont have mods that require you to use 91 then just go with 87 since your motor is designed to run on 87. i run 91 in my truck, i only have a few mods but in my truck i noticed it runs smoother and better on 91 so thats what i use, IMO 91 octane is worth the extra buck or 2 for my truck to run smoother and better.
 

MadMatt

New Member
If you dont use the toyota oil filter, you may get a tick for about 30 seconds during a cold start, toyota filters have a valve in it to prevent oil from draining all the way out of the top end.

Pretty sure the Fram Tough Gaurd has the anti-drainback valve, it should say on the package if it has one, the cheap models might not, but almost every premium model regardless of brand should have it if the application requires it.
 
Top