TSB: Clutch Pedal Squeak Noise '05-'06

TitanRattler813

Well-Known Member
Even my 07 squeaks, but it's not consistent enough to take to the dealer. I already know when I get there, I'll go to show it to them and nothing will happen :laugh: ... My stereo is generally turned up pretty high anyway, but it did annoy me for a while
 

SickRedXRnr

"OK, Good Talk"
bringing this back..... WOW my clutch sounds like crap... i called toyota and they said they will do NOTHING for me if its past the 36k mark... but it didn't start til after... so how is that my fault? is there anyone that has fixed this them self? if not how much does it cost to get done if its not under warranty...?
 

07bspXR

New Member
My 07 with 14k has the squeak too It drives me insane. Im going to take it to the dealer to see whats up with it.
 

morcheez

New Member
i cant believe they havent fixed this problem yet...even the 08's are doing it still...wonder if the 09's will still be doing this
 

Spyder327

New Member
Yeah, had the TSB done along time ago and i noticed today thats it's starting to comeback, gotta find a fix for this since I'm out of the 3yr 36k warranty. :thumpdown:

You know, i had mine done a looong time ago, and for the longest time it never came back. Then like 8 months ago it came back for like 2 weeks, then totally disappeared again:dontknow:

I think it just likes to mess with me:laugh:
 

PLCX

Active Member
Yeah, had the TSB done along time ago and i noticed today thats it's starting to comeback, gotta find a fix for this since I'm out of the 3yr 36k warranty. :thumpdown:

could you take it in and pay for it through the dealership? im in the same boat
 

Spyder327

New Member
could you take it in and pay for it through the dealership? im in the same boat

The main problem is that the "fix" for it doesn't always seems to be working. So if you were to pay for it out of pocket (being out of the 3/36) and the problem was still there, you would be SOL
 

firemedic_119

New Member
I talked to the dealer today here in lynchburg, va... they told me that if it doesnt do it when i bring it in then im SOL b/c the TSB say's 2005 and 2006... Mine is a 07.... Bastards
 
Top