Welcome!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Why does my X creak when the chassis flexes?

roy365

New Member
Joined
Jul 21, 2008
Messages
480
Reaction score
1
Anytime slowly pulling over a bump, etc or backing up it makes a creaking sound. Sometimes even just letting the clutch out. :hmmmm2: Is it bushings, or the leaf springs? Anyone ever tackled this? It's driving me batty. :stupid:
 

*IrunnIt*

Active Member
Joined
Jan 7, 2010
Messages
2,207
Reaction score
19
Any idea if the noise is coming from the inside, outside, front, back?
 

roy365

New Member
Joined
Jul 21, 2008
Messages
480
Reaction score
1
Back.....suspension related. I'm leaning towards the leaf springs. Not lowered.....nothing done to the suspension that I know of. I'm the second owner. Just didn't know if there is anything to do to fix it.
 

*IrunnIt*

Active Member
Joined
Jan 7, 2010
Messages
2,207
Reaction score
19
It might be the swaybar bushings, they start to makd noise after they get woren out. I know mine did.
 

nick_gz1

Active Member
Joined
Oct 26, 2011
Messages
1,705
Reaction score
21
well i got an almost brand new truck put 15k on it and it has that squek also
 

JiNsEiGaNaI

Active Member
Joined
Feb 20, 2011
Messages
1,424
Reaction score
4
mine does that too! too bad mine is out of the 36,000/3 yrs too! damn
 
Last edited:

butters607

Active Member
Joined
Oct 3, 2009
Messages
3,826
Reaction score
0
Mine too I have narrowed it to the rear end either sway bar bushings or shock bushings

TSB on Leaf springs, Mine had that also:top:

Can't be because I have the steel leads from xii performance
 
Last edited:

RE_TRD_X808

New Member
Joined
Jun 10, 2009
Messages
152
Reaction score
0
Back.....suspension related. I'm leaning towards the leaf springs. Not lowered.....nothing done to the suspension that I know of. I'm the second owner. Just didn't know if there is anything to do to fix it.

I had the same problem, Stock and Dropped. I sprayed white lithium grease on the leaf spring clamps and it went away. wd40 works too.
 

madtrucker

Well-Known Member
Joined
Feb 28, 2012
Messages
1,379
Reaction score
77
Mine does it too. It's pretty noisy when I go over uneven ground w/ the windows down.
 

roy365

New Member
Joined
Jul 21, 2008
Messages
480
Reaction score
1
I had the same problem, Stock and Dropped. I sprayed white lithium grease on the leaf spring clamps and it went away. wd40 works too.

Looks like those new pads/shims are supposed to take care of it. Nothing to the install either it seems.
 

Nashman

Active Member
Joined
Oct 22, 2015
Messages
446
Reaction score
43
most of the time it the front bumper support since it looses up over time mine does it just have not bother to tighten up the bolts yet
 
Top Bottom